Firmware Version : ardupilot-mpng-3.0.1-R2

 

S/W 변경은 다 한 것 같은데.. 실제 플라잉을 해 보면 스로틀을 조금만 올려도 휙휙!! 뒤집어졌다.

 

지자계, 가속도, Controller를 아무리 Calibration을 다시해 보아도 결과는 동일!! ㅠㅜ

미션플래너의 HUD에서는 문제가 없어보이는데..

 

거기다가 다른기체로 같이 작업하시는 분도 동일한 증상이 발생한다고 하니..

 

처음엔 펌웨어를 의심하기 시작했다. (이 버전 이상한거 아니야?! 엘리베이터도 반대고...)

 

낮은 버전으로 바꿔보까?! 하다가 3.0.1-R3이 나와 두개를 비교하니.. 모터출력부분, 수신기입력부분, 자세 측정부분 머 딱히 문제될만한 부분을 변경한 것은 없었다. 거기다가 이미 홈페이지에는 플라잉 동영상도 있다.

 

이건 거의(?) 내가 잘못하고 있는것이다!! 라고 늦게 알아버렸다.

 

여기저기 카페에 이것저것 글도 뒤적 뒤적 해 보고, 구글신께 물어도 보았다.

 

그러다가 알게된 사실1. (카페에서 찾음!!)

엘리베이터를 리버스 해줘야한다!! 앞으로 밀었을때 미션플래너의 게이지 상승!! 뒤로 당겼을때 게이지 하강!!

 

그런데 여전히 스로틀을 조금만 올렸을때 오른쪽에서 왼쪽으로 휙!! 휙!! 뒤집어 지는 문제는 알 수 없었다.

 

그래서 차근 차근 다시 해 보기로 마음먹고.

 

펌웨어 수정한 부분을 다시 확인해 보고!!

미션플래너에 연결해서 지자계 센서도 Calibration하고!! 가속도 센서도 Calibration하고!! Controller도 Calibration하고!!

ESC Calibration?! (이전(멀티위 시절!!)에 했었는데.. 에잇 한 번 더 해주지 머..)

 

ESC Calibration 중 스로틀을 살짝 올렸다. (어라.. 모터 소리가 부드러운데?! 먼가 달라!!)

그래서 프롭을 다시 연결하고 스로틀을 올려봤다.

(우와!! 잘난다.) 이전에 휙휙!! 돌아가던 증상은 싹! 없어졌다.

 

문제는 ESC Calibation 이었던 것이다. 이전에 해 줬었는데.. 안해줘도 되겠지 했던것이 큰 착각이었다.

< ESC Calibration 관련 Link >

http://copter.ardupilot.com/wiki/initial-setup/esc-motor/

=> 전압 체크 핀을 연결하지 않아서 그런지.. 셀 체크 비프음은 나지 않았다. 


역시.. 되겠지 하고 생각했던 것들이 후에 큰 문제가 되었다. 반성해야겠다!!ㅠㅜ

Posted by 크릴새우

댓글을 달아 주세요

이전버튼 1 2 3 4 5 6 7 8 9 10 ··· 41 이전버튼

블로그 이미지
크릴새우

태그목록

공지사항

Yesterday8
Today1
Total30,573

달력

 « |  » 2020.12
    1 2 3 4 5
6 7 8 9 10 11 12
13 14 15 16 17 18 19
20 21 22 23 24 25 26
27 28 29 30 31    

글 보관함